Back to overview
Downtime
TimePlan Cloud (.com), Timegrip Cloud (.com), and 1 other service are down
Aug 28 at 03:36pm CEST
Affected services
TimePlan Cloud (.com)
Timegrip Cloud (.com)
TimePlan Analytics
Resolved
Aug 28 at 03:50pm CEST
TimePlan Cloud (.com), Timegrip Cloud (.com), and TimePlan Analytics recovered.
Affected services
Created
Aug 28 at 03:36pm CEST
TimePlan Cloud (.com), Timegrip Cloud (.com), and TimePlan Analytics went down.
Affected services